I am at present establishing a prototype ring (or small mesh) community utilizing MSTP, and I am operating into a difficulty with path choice. The community consists of three switches:
-
Change N: Juniper EX2300-C (serving because the core distribution swap)
-
Change S: Juniper EX2300-C
-
Change A: Cisco Catalyst 3560-CX
These three switches are interconnected in a hoop topology utilizing 1G SFP modules and LC-LC fiber cables. The aim is for Change N (the core) to have connectivity to Change A through Change S — i.e., we would like the trail N → S → A to be the first forwarding path, and the direct hyperlink N → A for use solely as a backup or failover.
This is what we have now configured thus far:
-
All switches are operating MSTP and are in the identical MST area.
-
We elevated the port value and port precedence on the N → A hyperlink to attempt to discourage its use.
Regardless of this, MSTP continues to decide on the direct N → A hyperlink because the lively path, reasonably than the specified N → S → A path.
I’ll connect a tough topology diagram and related MSTP configuration snippets for context.
MSTP and interface configuration snippets:
Change N: Juniper EX2300-C
set protocols mstp configuration-name AMBA-DIST
set protocols mstp revision-level 1
set protocols mstp bridge-priority 0
set protocols mstp interface ge-0/1/0 value 50000
set protocols mstp interface ge-0/1/1
Interfaces:
set interfaces ge-0/1/0 description N-A
set interfaces ge-0/1/0 unit 0 household ethernet-switching interface-mode trunk
set interfaces ge-0/1/0 unit 0 household ethernet-switching vlan members all
set interfaces ge-0/1/1 description N-S
set interfaces ge-0/1/1 unit 0 household ethernet-switching interface-mode trunk
set interfaces ge-0/1/1 unit 0 household ethernet-switching vlan members all
Change S: Juniper EX2300-C
set protocols mstp configuration-name AMBA-DIST
set protocols mstp revision-level 1
set protocols mstp bridge-priority 32k
set protocols mstp interface ge-0/1/0
set protocols mstp interface ge-0/1/1
Interfaces:
set interfaces ge-0/1/0 description S-N
set interfaces ge-0/1/0 unit 0 household ethernet-switching interface-mode trunk
set interfaces ge-0/1/0 unit 0 household ethernet-switching vlan members all
set interfaces ge-0/1/1 description S-A
set interfaces ge-0/1/1 unit 0 household ethernet-switching interface-mode trunk
set interfaces ge-0/1/1 unit 0 household ethernet-switching vlan members all
Change A: Cisco Catalyst 3560-CX
spanning-tree mode mst
spanning-tree prolong system-id
!
spanning-tree mst configuration
title AMBA-MST
revision 1
occasion 1 vlan 12
!
spanning-tree mst 1 precedence 24576
spanning-tree vlan 12 precedence 4096
Interfaces:
interface GigabitEthernet1/0/15
description A-S
switchport mode trunk
spanning-tree mst 1 port-priority 64
spanning-tree mst 1 value 20000
!
interface GigabitEthernet1/0/16
description A-N
switchport mode trunk
spanning-tree mst 1 value 50000
Query:
Why would possibly MSTP nonetheless be preferring the N → A path regardless of its greater value and precedence? What ought to I examine or alter to make sure that N → S → A is the popular forwarding path?
Any insights or recommendations could be vastly appreciated!
Thanks upfront!