colleagues.
I’m fixing the duty of migrating a number of VLANs from MikroTik to a newly deployed core community, constructed from two Huawei CE6863E switches mixed utilizing M-LAG.
Goal: take away all inner networks from MikroTik in order that it turns into a PE (Supplier Edge).
We determined to start out with VLAN 203, which is liable for VoIP. I encountered an issue: after enabling the VLAN on the core (after disabling it on MikroTik), pinging hosts on this community is just potential from MSK-Core-1. From MSK-Core-2, there isn’t any ping to any host aside from the IP tackle of the VLAN 203 interface itself, which is the gateway for this community.
MSK-Core-1 configuration:
dfs-group 1
precedence 200
supply ip 10.197.255.254
consistency-check allow mode unfastened
stp bridge-address 0001-0001-0001
stp mode rstp
stp v-stp allow
stp occasion 0 root main
stp tc-protection
arp direct-route allow
bridge-domain 1
arp l2-proxy allow
interface Vlanif203
description Vo-Ip
ip tackle 10.197.203.254 255.255.255.0
arp proxy allow
arp proxy inter-vlan allow
arp proxy intra-vlan allow
mac-address 0000-5e00-0101
dhcp server allow
dhcp choose relay
dhcp relay binding server group ad-dhcp-srv
dhcp relay source-interface Vlanif203
interface MEth0/0/0
ip tackle 10.197.1.101 255.255.255.0
arp detect mode unicast
interface Eth-Trunk0
stp disable
mode lacp-static
peer-link 1
port vlan exclude 1
interface 25GE1/0/1
description Hyperlink-MikroTik-Sfp2
port link-type trunk
undo port trunk allow-pass vlan 1
port trunk allow-pass vlan 2 to 499 501 to 4094
gadget transceiver 10GBASE-FIBER
port mode 10G
interface LoopBack0
ip tackle 10.197.255.254 255.255.255.255
bgp 65197
router-id 10.197.255.254
private-4-byte-as allow
peer 10.197.255.253 as-number 65197 # MSK-Core-2
peer 10.197.255.253 connect-interface LoopBack0
peer 10.197.255.253 capability-advertise graceful-restart
peer 10.197.255.255 as-number 65197 # MikroTik
peer 10.197.255.255 connect-interface LoopBack0
peer 10.197.255.255 capability-advertise graceful-restart
#
ipv4-family unicast
community 10.197.203.0 255.255.255.0
community 10.197.255.254 255.255.255.255
peer 10.197.255.253 allow
peer 10.197.255.255 allow
peer 10.197.255.255 preferred-value 50
ip route-static 0.0.0.0 0.0.0.0 10.197.255.255
ip route-static 10.197.255.253 255.255.255.255 10.197.1.102
ip route-static 10.197.255.255 255.255.255.255 10.197.1.254
MSK-Core-2 configuration (much like MSK-Core-1):
dfs-group 1
precedence 150
supply ip 10.197.255.253
consistency-check allow mode unfastened
stp occasion 0 root secondary
interface LoopBack0
ip tackle 10.197.255.253 255.255.255.255
bgp 65197
router-id 10.197.255.253
private-4-byte-as allow
peer 10.197.255.254 as-number 65197 # MSK-Core-1
peer 10.197.255.254 connect-interface LoopBack0
peer 10.197.255.254 capability-advertise graceful-restart
peer 10.197.255.255 as-number 65197
peer 10.197.255.255 connect-interface LoopBack0
peer 10.197.255.255 capability-advertise graceful-restart
#
ipv4-family unicast
community 10.197.203.0 255.255.255.0
community 10.197.255.253 255.255.255.255
peer 10.197.255.254 allow
peer 10.197.255.255 allow
peer 10.197.255.255 preferred-value 50
ip route-static 0.0.0.0 0.0.0.0 10.197.255.255
ip route-static 10.197.255.254 255.255.255.255 10.197.1.101
ip route-static 10.197.255.255 255.255.255.255 10.197.1.254
M-LAG:
show dfs-group 1 m-lag
* : Native node
Coronary heart beat state : OK
Node 1 *
Dfs-Group ID : 1
Precedence : 200
Tackle : ip tackle 10.197.255.254
State : Grasp
Causation : -
System ID : e84d-7424-0b11
SysName : MSK-Core-1
Model : V200R022C00SPC500
System Sort : CE6863E
Node 2
Dfs-Group ID : 1
Precedence : 150
Tackle : ip tackle 10.197.255.253
State : Backup
Causation : -
System ID : e8ea-4d4a-6af1
SysName : MSK-Core-2
Model : V200R022C00SPC500
System Sort : CE6863E
Routing:
dis bgp routing-table
*> 10.197.203.0/24 0.0.0.0 0 0 i
dis bgp routing-table
*> 10.197.203.0/24 0.0.0.0 0 0 i
[~MSK-Core-1-Vlanif203]dis ip routing-table 10.197.203.0
10.197.203.0/24 Direct 0 0 D 10.197.203.254 Vlanif203
[~MSK-Core-2-Vlanif203]dis ip routing-table 10.197.203.0
10.197.203.0/24 Direct 0 0 D 10.197.203.254 Vlainf203
ARP:
[~MSK-Core-1]dis arp | i 10.197.203.
10.197.203.254 0000-5e00-0101 I Vlanif203
10.197.203.1 bc24-1166-e8bc 20 D/203 25GE1/0/40
10.197.203.19 44db-d26b-e3b5 20 D/203 25GE1/0/2
[~MSK-Core-2]dis arp | i 10.197.203.
# There are numerous extra entries, and all of them are by way of Eth-Trunk0
10.197.203.254 0000-5e00-0101 I Vlanif203
10.197.203.1 bc24-1166-e8bc 20 D/203 Eth-Trunk0
10.197.203.19 44db-d26b-e3b5 20 D/203 Eth-Trunk0
Ping:
[~MSK-Core-1]ping 10.197.203.1
Reply from 10.197.203.1: bytes=56 Sequence=1 ttl=64 time=1 ms
[~MSK-Core-2]ping 10.197.203.1
Request day trip
I need assistance fixing this challenge. The place ought to I look? What did I configure incorrectly?