14.3 C
New York
Tuesday, March 25, 2025

Cisco inter-vlan routing with a number of routers


I’m making an attempt to allow inter-vlan routing, however one thing is definitely not working.

Every of the computer systems is assigned to corresponding vlans, each switch-to-switch and switch-to-router hyperlink is configured as trunk with vlans 10, 20 and 30 allowed. The switches have their corresponding vlans and vlan ip assigned (S1 – vlan 10, S2 – vlan 20, S3 – vlan 30). Every router has a configured subinterface assigned to the suitable vlans. Computer systems can ping their gateways (subinterface IP deal with), however nothing else.

I have to configure static routing, however i am not fairly positive what my subsequent hop deal with ought to be, and if i am lacking one thing else within the configuration.

the topology

R1 config:

interface GigabitEthernet0/0/0
 no ip deal with
 duplex auto
 velocity auto
!
interface GigabitEthernet0/0/0.1
 encapsulation dot1Q 10
 ip deal with 192.168.10.1 255.255.255.0

R2 config:

interface GigabitEthernet0/0/0
 no ip deal with
 duplex auto
 velocity auto
!
interface GigabitEthernet0/0/0.2
 encapsulation dot1Q 20
 ip deal with 192.168.20.1 255.255.255.0

R3 config:

interface GigabitEthernet0/0/0
 no ip deal with
 duplex auto
 velocity auto
!
interface GigabitEthernet0/0/0.3
 encapsulation dot1Q 30
 ip deal with 192.168.30.1 255.255.255.0

S1 config:

no spanning-tree vlan 10,20,30
spanning-tree mode pvst
spanning-tree prolong system-id
!
interface FastEthernet0/10
 switchport entry vlan 10
 switchport trunk allowed vlan 10,20,30
 switchport mode trunk
!
interface GigabitEthernet0/1
 switchport trunk allowed vlan 10,20,30
 switchport mode trunk
!
interface GigabitEthernet0/2
 switchport trunk allowed vlan 10,20,30
 switchport mode trunk
!
interface Vlan1
 no ip deal with
 shutdown
!
interface Vlan10
 ip deal with 192.168.10.100 255.255.255.0

S2 config:

no spanning-tree vlan 10,20,30
spanning-tree mode pvst
spanning-tree prolong system-id
!
interface FastEthernet0/10
 switchport entry vlan 20
 switchport trunk allowed vlan 10,20,30
 switchport mode trunk
!
interface GigabitEthernet0/1
 switchport trunk allowed vlan 10,20,30
 switchport mode trunk
!
interface GigabitEthernet0/2
 switchport trunk allowed vlan 10,20,30
 switchport mode trunk
!
interface Vlan1
 no ip deal with
 shutdown
!
interface Vlan20
 ip deal with 192.168.20.100 255.255.255.0

S3 confing:

no spanning-tree vlan 10,20,30
spanning-tree mode pvst
spanning-tree prolong system-id
!
interface FastEthernet0/10
 switchport entry vlan 30
 switchport trunk allowed vlan 10,20,30
 switchport mode trunk
!
interface GigabitEthernet0/1
 switchport trunk allowed vlan 10,20,30
 switchport mode trunk
!
interface Vlan1
 no ip deal with
 shutdown
!
interface Vlan30
 ip deal with 192.168.30.100 255.255.255.0

S4 config (the one related to the computer systems):

no spanning-tree vlan 10,20,30
spanning-tree mode pvst
spanning-tree prolong system-id
!
interface FastEthernet0/1
 switchport entry vlan 10
 switchport mode entry
!
interface FastEthernet0/2
 switchport entry vlan 20
 switchport mode entry
!
interface FastEthernet0/3
 switchport entry vlan 30
 switchport mode entry
!
interface GigabitEthernet0/1
 switchport trunk allowed vlan 10,20,30
 switchport mode trunk

Related Articles

LEAVE A REPLY

Please enter your comment!
Please enter your name here

Latest Articles